Reached EOF Error Win10 20H2

Home Forums Help and Support Reached EOF Error Win10 20H2

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #37441

    errorEOF
    Participant
    • Offline

    Hi all, I am running into an error with Colormunki Display on Windows 10 20H2. X-Rite Devices Service Manager is not running, and Argyll_V2.3.1 is installed/binaries exist–please find the log attached below (and also attached):

    19:13:41,763 Calibrate & profile
    19:13:42,466 Detecting output levels range...
    19:13:42,466 --------------------------------------------------------------------------------
    19:13:42,466 Session log: 0_16
    19:13:42,466 
    19:13:42,466 Working directory:
    19:13:42,466 c:\
    19:13:42,466 users\
    19:13:42,466 blue\
    19:13:42,466 appdata\
    19:13:42,466 local\
    19:13:42,466 temp\
    19:13:42,466 DisplayCAL-gmjjeg\
    19:13:42,466 
    19:13:42,466 Command line:
    19:13:42,466 C:\Users\blue\Downloads\Argyll_V2.3.1_win64_exe\Argyll_V2.3.1\bin\dispread.exe
    19:13:42,466 -v
    19:13:42,466 -k
    19:13:42,466 C:\Users\blue\Downloads\DisplayCAL-3.8.9.3-win32\DisplayCAL-3.8.9.3\linear.c
    19:13:42,466 al
    19:13:42,466 -d1
    19:13:42,466 -c1
    19:13:42,466 -yn
    19:13:42,466 "-P0.5,0.5,50.0"
    19:13:42,466 0_16
    19:13:42,466 
    19:13:42,801 DisplayCAL: Starting interaction with subprocess
    19:13:42,801 Number of patches = 3
    19:13:42,801 Setting up the instrument
    19:13:43,644 Product Name: Colormunki Display
    19:13:43,644 Serial Number: redacted
    19:13:43,644 Firmware Version: v1.03
    19:13:43,644 Firmware Date: 05Jun12
    19:13:44,301 DisplayCAL: Reached EOF (OK)
    19:13:44,301 dispread exitcode: -1073741819
    19:13:44,301 ...aborted.
    Attachments:
    You must be logged in to view attached files.

    i1Display Studio on Amazon  
    Disclosure: As an Amazon Associate I earn from qualifying purchases.

    #37538

    Martin Winkelmann
    Participant
    • Offline

    Hi,

    I am seeing the same issue on Windows 11 22H2, did you mean that by any chance (mistyped 22 -> 20?).

    Worked fine just a couple days ago before I reinstalled Windows for 22H2. The version numbers for DisplayCal and ArgyllCMS are identical.

    #37540

    Martin Winkelmann
    Participant
    • Offline

    Update: I haven’t gotten around to doing a full calibration yet but it seems like using the x86/32bit version of ArgyllCMS works!

    #37627

    Martin Winkelmann
    Participant
    • Offline

    Final Update: I got in touch with Graeme Gill, the ArgyllCMS developer. The “2.3.1b” build was created in a newer build environment, the issue is most likely that DisplayCAL can’t properly communicate with these ArgyllCMS builds, possibly due to a change in the used stdio library. There is a new build out now “2.3.1d” (same download link as the other “2.3.1” versions),  which should work with DisplayCAL again. I ran a calibration with my I1D3 and everything worked as expected.

    #37633

    Vincent
    Participant
    • Offline

    Where can I find that version?

    If I download latest win64 executables:

    Version 2.3.1b 20th October 2022
    ————-

    * MSWindows fix release for SpyderX

    #37642

    Martin Winkelmann
    Participant
    • Offline

    The update hasn’t been documented (yet?), if you download it now you should get the fixed version.

    Do you have any issues when using the currently available version?

    #37644

    Vincent
    Participant
    • Offline

    I had no issues with 2.3.1 without letter, 22H2 19045.2193, i1d3 & i1Pro2 (with 2.1.2 USB driver for i1Pro2, last one signed by DisplayCAL)

    • This reply was modified 3 weeks, 1 day ago by Vincent.
    #37931

    Martin Winkelmann
    Participant
    • Offline

    I had no issues with 2.3.1 without letter, 22H2 19045.2193, i1d3 & i1Pro2 (with 2.1.2 USB driver for i1Pro2, last one signed by DisplayCAL)

    The a/b/c/d versions silently replaced the file downloaded from the website, and only b got an entry in the changelog for the SpyderX fix.

    SHA256 Checksum of 64bit 2.3.1a/no letter .zip file

    dc6b8da23acd675c45a610738be207c856a8d42d99f923967f67b153f243310c

    Checksum for 64bit 2.3.1d:

    4c5d8be37b2656f5ae92cb2612b029bc15b030c40e59a6e3b58657852d998a3f

    The change date of the files of the original 2.3.1 should be 2022-06-28, for 2.3.1d it’s  ‎2022-‎11-‎04 (both UTC).

    The first 2.3.1 version works, the 64bit 2.3.1 b and c builds had the issue, the 2.3.1 d build works fine again. The 32bit versions may have never had the issue.

    For anyone finding this thread, if you download ArgyllCMS right now, you should be getting a version that works with DisplayCAL.

    I also want to reiterate that ArgylCMS itself always worked, it’s just that DisplayCAL wasn’t compatible with some builds; just want to make sure no one thinks that this was a QA problem on ArgyllCMS’s side.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Log in or Register

Display Calibration and Characterization powered by ArgyllCMS