3D LUT creation workflow for Resolve

Wikis > 3D LUT creation workflow for Resolve

Table of Contents

  • Prerequisites
  • Pattern generator workflow (requires DisplayCAL 3.0+ and Resolve 10.1+)
  • Creating a 3D LUT for the GUI color viewer
  • Creating additional 3D LUTs with different settings from existing measurements

Prerequisites

  • If you are using a colorimeter that supports it (e.g. i1 DisplayPro, ColorMunki Display or Spyder 4/5), you may want to import and use one of the vendor spectral corrections for your display type. Select “Import colorimeter corrections from other software” in the “Tools” menu, and make sure i1Profiler is selected. Click the “Auto” button.
  • After you’ve successfully imported the files, they are listed under “Corrections” on the “Display & instrument” tab. Choose one that matches your display technology if possible.

Pattern generator workflow (requires DisplayCAL 3.0+ and Resolve 10.1+)

IMPORTANT This workflow is for creating a 3D LUT for a display that is not part of the desktop (e.g. connected via a decklink card or similar). If you want to create a 3D LUT for the Resolve GUI color viewer, see “Creating a 3D LUT for the GUI color viewer” further below.

  • In DisplayCAL, choose the “3D LUT for Resolve (D65, Rec. 709 / 1886)” preset under “Settings”.
  • If using an OLED, Plasma, or other display with variable light output depending on picture content, enable white level drift compensation.
  • Note that Argyll CMS automatically calculates and uses a delay when measuring displays, to allow for things such as display update delay and settle time. When Resolve is used as pattern generator (see important note above, the following paragraph does not apply in that case), an increased minimum delay is needed, which is by default 600ms and should work well in most cases. To check if you need to alter this, you can run a quick profile with the “Small testchart for LUT profiles” (154 patches, select it under the “Profiling” tab) and look at the profile self check error. If it’s much higher than 0.5 DE average and 5 DE peak, there’s a high likelihood of misreads due to the used delay not being quite enough. You can set a higher delay by going into the “Options” menu, enabling “Show advanced options”, and then adjusting the delay on the “Display & instrument” tab. Increase in steps of 50-100ms until the self check errors are in the mentioned ballpark. Don’t forget to set the testchart on the “Profiling” tab back to “Auto” after you have established a delay that works.
  • If desired, adjust the amount of measured patches under the “Profiling” tab. The default 1553 patches should already give good results. More patches increase measurement and profile processing time as well as characterization accuracy. If you need to save time, you may reduce the amount of measured patches at the cost of accuracy. If the display is well-behaved, the effect may be negligible.
  • The “Resolve” preset is set up to not use iterative gray balance calibration, as normally it shouldn’t be needed. If you do want to use iterative gray balance calibration, set calibration tone curve on the “Calibration” tab from “As measured” to “Rec. 1886” (or another desired curve). Note that this setting does not influence the 3D LUT tone curve, which you can adjust in the next step.
  • If you want to target a different tone curve for the 3D LUT, go to the “3D LUT” tab and adjust the options as desired. E.g. to target a gamma 2.2 “output offset” (pure power) curve, set tone curve to “Gamma 2.2”. A blend between input offset (BT.1886) and output offset can be achieved by setting tone curve to “Custom” and output offset between 0% and 100%.
  • If desired, adjust the 3D LUT output format and encoding.
  • Click “Calibrate & profile”.
  • A message “Waiting for connection on IP:PORT” should appear. Note the IP and port numbers.
  • In Resolve, switch to the “Color” tab and then choose “Monitor calibration”, “CalMAN” in the “Color” menu (Resolve version 11 and earlier) or the “Workspace” menu (Resolve 12).
  • Enter the IP address in the window that opens (port should already be filled) and click “Connect”.
  • Drag the measurement window to the desired location and size. A size that’s just large enough to fit the instrument comfortably inside the area is usually best (unless you use the instrument in non-contact mode in which case a larger size may be required). For Resolve, APL patterns with roughly 22% level will be used by default unless you enable “Black background”. The position of the window will be mimicked on the display you have connected via Resolve after you click “Start measurement”.
  • DisplayCAL should show a confirmation to place the instrument on the designated spot. Click OK.
  • Use the interactive display adjustment window to adjust whitepoint and luminance before starting profiling measurements.
  • After the measurements and profile calculations are finished, a window will appear which shows the profile self check error as well as gamut coverage. The self check error should not be higher than 0.5 DE average and 5 DE peak. Click “Save 3D LUT…” to select a location where it should be saved. Resolve searches for LUTs in the folders
    C:\ProgramData\Blackmagic Design\DaVinci Resolve\Support\LUT (Windows) or
    /Library/Application Support/Blackmagic Design/DaVinci Resolve/LUT (Mac OS X)
  • If you want, you can verify the 3D LUT you have just created by going to the “Verification” tab and clicking the “Measurement report” button. The settings should already be correct for the chosen 3D LUT parameters, but you may want to choose a larger or different testchart (the default one only has 26 patches and is suitable for a quick check, which ideally should be followed up by a more thorough examination with a larger chart).

Using the 3D LUT in Resolve

Open the “File” menu in Resolve and select “Project settings…”. Select “Color Management” (in older versions “Lookup Tables”) from the list. Choose your 3D LUT under the “3D Video Monitor Lookup Table” entry. Note that you should set your scopes to not use the video monitor selection (see below how to create a 3D LUT for the color viewer). You can also set 3D Lookup Table Interpolation to “Tetrahedral” for potentially better accuracy.

Creating a 3D LUT for the GUI color viewer

IMPORTANT This workflow is for creating a 3D LUT for the Resolve GUI color viewer on a display that is part of the desktop. If you want to create a 3D LUT for a display that is connected through e.g. a decklink card or similar, see “Pattern generator workflow” above.

  • In DisplayCAL, choose the “3D LUT for Resolve (D65, Rec. 709 / 1886)” preset under “Settings”.
  • Select your actual display device under the display dropdown instead of Resolve.
  • If using an OLED, Plasma, or other display with variable light output depending on picture content, enable white level drift compensation.
  • If desired, adjust the amount of measured patches under the “Profiling” tab. The default 1553 patches should already give good results. More patches increase measurement and profile processing time as well as characterization accuracy. If you need to save time, you may reduce the amount of measured patches at the cost of accuracy. If the display is well-behaved, the effect may be negligible.
  • The “Resolve” preset is set up to not use iterative gray balance calibration, but as we are going to create a profile that will also be installed to the operating system, you may want to enable it. Set calibration tone curve on the “Calibration” tab from “As measured” to “Rec. 1886” (or another desired curve). Note that this setting does not influence the 3D LUT tone curve, which you can adjust in the next step.
  • IMPORTANT If you have opted to do iterative gray balance calibration, enable advanced options in the “Options” menu, then go to the “3D LUT” tab and disable “Apply calibration (vcgt)”. This is very important because while Resolve does not make use of the display ICC profile, it’s user interface is still affected by the 1D calibration of the profile we’re going to install later, so applying it to the 3D LUT would result in the calibration being applied twice.
  • If you want to target a different tone curve for the 3D LUT, go to the “3D LUT” tab and adjust the options as desired. E.g. to target a gamma 2.2 “output offset” (pure power) curve, set tone curve to “Gamma 2.2”. A blend between input offset (BT.1886) and output offset can be achieved by setting tone curve to “Custom” and output offset between 0% and 100%.
  • If desired, adjust the 3D LUT output format and encoding.
  • Click “Calibrate & profile”.
  • Drag the measurement window to the desired location and size. A size that’s just large enough to fit the instrument comfortably inside the area is usually best (unless you use the instrument in non-contact mode in which case a larger size may be required). Click “Start measurement”.
  • Use the interactive display adjustment window to adjust whitepoint and luminance before starting calibration/profiling measurements.
  • After the measurements and profile calculations are finished, a window will appear which shows the profile self check error as well as gamut coverage. The self check error should not be higher than 0.5 DE average and 5 DE peak. Click “Save 3D LUT…” to select a location where it should be saved. Resolve searches for LUTs in the folders
    C:\ProgramData\Blackmagic Design\DaVinci Resolve\Support\LUT (Windows) or
    /Library/Application Support/Blackmagic Design/DaVinci Resolve/LUT (Mac OS X).
  • Go to the “Display & instrument” tab. Click the small “Install profile” button next to the settings dropdown, and install the profile.
  • If you want, you can verify the 3D LUT you have just created by going to the “Verification” tab and clicking the “Measurement report” button. Enable the “DeviceLink profile” checkbox. The other settings should already be correct for the chosen 3D LUT parameters, but you may want to choose a larger or different testchart (the default one only has 26 patches and is suitable for a quick check, which ideally should be followed up by a more thorough examination with a larger chart).

Using the 3D LUT in Resolve

Open the “File” menu in Resolve and select “Project settings…”. Select “Color Management” (in older versions “Lookup Tables”) from the list. Choose your 3D LUT under the “3D Color Viewer Lookup Table” entry. You can also set 3D Lookup Table Interpolation to “Tetrahedral” for potentially better accuracy.

Creating additional 3D LUTs with different settings from existing measurements

You can create additional 3D LUTs from any existing profile selected under “Settings” by going to the “3D LUT” tab and disabling “Create 3D LUT after profiling”. The button at the bottom will change to “Create 3D LUT…”. You can now adjust the 3D LUT settings and create as many additional LUTs as you like.

17 thoughts on “3D LUT creation workflow for Resolve”

  1. Have a question on creating a 3D LUT for the GUI color viewer/scopes on Macbook Retina internal LCD

    I already have a calibrated sRGB ICC profile installed and I’d rather leave it system wide. Can I still use it and get Resolve viewer calibrated to REC.709?

    Sorry for answering but your workflow leaves a few options:The “Resolve” preset is set up to not use iterative gray balance calibration, but as we are going to create a profile that will also be installed to the operating system, you MAY want to enable it.

    Is it necessary to install DisplayCAL profile systemwide after creating 3D LUT? Why I may want to use iterative gray balance calibration?

    With the new option in Resolve:
    Use Mac Display color profile for viewers under Project settings/Color management, if I leave it on and install DisplayCAL profile I get HUE shift in the viewer. Here are the samples with different combinations of System ICC profiles in MacOS. Mac Display Color and  3D LUT in Resolve.

    Screenshots Download

    Mac built in preview looks different than my Chrome Browser, Hue shifted screens are fine and the others are shifted, but I hope you’ll see it even on Windows. Is this a bug or a feature? 🙂

    So what should I choose for calibration / profiling settings?

    Calibration tab:
    – Is it safe to disable “Interactive display adjustment” as the laptop screen can only change brightness, or you use DDC controls, or else?

    3D LUT tab:

    – Apply calibration (VCGT), it only applies the DisplayCAL measured corrections?

    On the pop-up menu after I press Profile:

    – The current calibration will be used.
    Does it mean DisplayCAL will pick up my System wide ICC?

    – Embed calibration curves in profile.
    Which profile? 3D LUT .cube?

    Sorry for lots of questions. Will try to figure out on my own by fiddling with these settings, but will be happy to know your opinion.

  2. And thank you for great soft Florian!

    Just in case I’m on a MacBook Retina 15″ MacOSX 10.10.3, DaVinci Resolve 12.1

  3. Is it necessary to install DisplayCAL profile systemwide after creating 3D LUT? Why I may want to use iterative gray balance calibration?

    If creating a 3D LUT for the GUI viewer, then the 3D LUT needs to be built from the same profile as the one assigned to the display to make sure the video card gamma table is valid for the 3D LUT as well. Although, there is the option to use an existing display profile (as long as it’s an ICCv2 profile) by choosing “<Current>” under “Settings” in DisplayCAL instead of creating/installing a new profile.

    Use Mac Display color profile for viewers under Project settings/Color management, if I leave it on and install DisplayCAL profile I get HUE shift in the viewer.

    This means Resolve is using only the matrix tags in the profile which are deliberately hue shifted to make it obvious when they are used. Resolve should use the cLUT tags instead, but apparently ICC support in Resolve is quite limited. This should really be reported to BMD as a Resolve bug.

    Mac built in preview looks different than my Chrome Browser

    Yes, Preview has been buggy for me at least under El Capitan, possibly earlier. The wrong rendering in Preview also happens with profiles built by other profiling solutions (e.g. i1 Profiler). At the moment, I would therefore recommend not to use Preview for any color critical work.

    Is it safe to disable “Interactive display adjustment” as the laptop screen can only change brightness

    Yes.

    Apply calibration (VCGT), it only applies the DisplayCAL measured corrections?

    Must be disabled/off if building a LUT for the Resolve GUI Viewer/Scopes, because any 1D calibration is already applied via the video card.

    Does it mean DisplayCAL will pick up my System wide ICC?

    Only the 1D calibration (VCGT).

    Which profile?

    The one you’re about to create. My recommendation is to always embed calibration (which should be the default).

    1. Thank you very much for fantastic immediate reply!

      So, if I want to:

      use an existing display profile (as long as it’s an ICCv2 profile) by choosing “<Current>” under “Settings” in DisplayCAL instead of creating/installing a new profile.

      How exactly do I proceed in LUT creation? Choose “Current” in DisplayCAL Settings, set up all tabs manually?

      And if I created profile based on  my system wide OSX .ICC display profile, should I enable Use Mac Display color profile for viewers?

  4. How exactly do I proceed in LUT creation? Choose “Current” in DisplayCAL Settings, set up all tabs manually?

    Choose the “Resolve” preset, then directly afterwards choose “<Current>”. Go to the 3D LUT tab, disable “Create 3D LUT after profiling”. Adjust 3D LUT options as outlined in the Wiki, click “Create 3D LUT…”. Voila 🙂

    And if I created profile based on  my system wide OSX .ICC display profile, should I enable Use Mac Display color profile for viewers?

    No, the 3D LUT will take care of colors.

  5. As soon as I disable “Create 3D LUT after profiling” the button to create LUT is greyed out. I guess my ICC made with basiccolor is non compliant… will try to make an sRGB profile with DisplayCAL and then make a 3D LUT based on it.

    Thank you again!

    1. As soon as I disable “Create 3D LUT after profiling” the button to create LUT is greyed out.

      I have the same problem, although I calibrated with Display Cal so the profile should be compliant. Did it work with you after you created a new profile with Display Cal, or is the button still greyed out?

  6. ok, now I figured it out. Here’s how I got it:

    1. I use my profile settings, then I click “Enable 3d LUT tab” in “Options”.

    2. Then I go to the Profiling tab and change Profile type to “XYZ LUT + swapped matrix”, click on the little wheel button, disable “enhance effective…” and select “Low quality PCS-to-device tables”.

    3. Then I go the 3D Lut tab and disable “Create 3D LUT after profiling” and “Apply calibration (vcgt)”.

    4. Now the “Create 3D LUT” button is not greyed out anymore.

    Is this correct, Florian? Using “current” the way you described earlier in this post didn’t work, because the “Create 3D LUT” button was greyed out.

    1. Is this correct, Florian? Using “current” the way you described earlier in this post didn’t work, because the “Create 3D LUT” button was greyed out.

      That’s right, using “<Current>” (meaning the currently assigned display profile) on the 3D LUT tab is not possible. You have to select a profile under “Settings”.

  7. Ok thanks for clearing that up , Florian! I really appreciate your help!

    Now that I installed the LUT as Viewer LUT in Davinci, I am little bit confused about the result.

    First of all, I am on a macOS 10.13.1 Hackintosh with a LG 31MU97 wide gamut Display connected to a NVIDIA 980ti 6GB graphic card using Displayport1.2. Before I calibrated the system according to this wiki using your standard for Video (D65, Rec. 1886) with LUT enabled, I did a hardware calibration using True Color Pro from LG to 6500K, 2.2 gamma and 80cd/m2 (my room is quite dark). Click here for the report.

    I graded some sample-footage (with LUT installed & “Use Mac Display Color Profiles..” switched off), and the first thing I noticed is that on the edit page the viewers looked completely different after grading (too saturated, reddish). It looks like the Viewer-LUT only applies to the Color tab in Davinci, am I right?

    Then I exported the sequence in ProRes 422HQ and opened it with the Quicktime Player and Safari. To my big surprise, in both programs the clip looked almost like in the Davinci viewer (although crashed shadows), whereas in VLC and IINA the same oversaturation and red tint as on the edit page in Davinci appeared. Is this behaviour normal?

    I always thought that the Quicktime Player was not to be trusted, or am I wrong? People always told me to use VLC for viewing on a computer.

    All I need is an image I can rely on, otherwise color correction and grading in Davinci is pointless. Oh, bye the way, I use an ACEScct workflow with ACES 1.0.3. with the Sony SLOG2 Daylight IDT and the Rec.709 ODT.

    Here’s what I mean, on top in the middle is my Davinci viewer, on the left side are Safari and Quicktime, right beneath and on the right side there’s VLC and IINA:

    And here are the settings I used to calibrate the monitor:

    1. Sorry, I just noticed that the embedded images don’t work. Here’s a link: https://www.dropbox.com/sh/ml0j5hsz7gziors/AACU834RdaPks2l1moEFTsd8a?dl=0

  8. It looks like the Viewer-LUT only applies to the Color tab in Davinci, am I right?

    Possibly.

    Then I exported the sequence in ProRes 422HQ and opened it with the Quicktime Player and Safari. To my big surprise, in both programs the clip looked almost like in the Davinci viewer (although crashed shadows) whereas in VLC

    No surprise here, QT Player and Safari use the system color management, while VLC has no notion of color correct rendering at all.

    I always thought that the Quicktime Player was not to be trusted, or am I wrong?

    For a quick preview it may be ok.

     

    1. do you have an explanation for the crushed blacks? should I use a 3d lut with srgb tone curve instead bt.1886. although I did calibrate to bt. 1886 according to your preset.

      1. do you have an explanation for the crushed blacks?

        It’s an OS X bug. it only affects Apple software (i.e. Preview, Photos, QT Player etc) and software relying on Apple’s color management functionality, not 3rd party apps that implement their own color management.

        1. Ok, thanks for your answer!

          Can you recommend a good video-player for macOS that does proper colormanagement?

          I tried IIna which is based on mplayerwith colormanagement activated, but I don‘t think it works properly. I used name: „icc-profile-auto“ value:“yes“. As far as I understood this should tell the player to use the displays icc-profile.

          Just to be sure if I understood calibration, profiling & colormanagement: It doesn‘t matter which gamma curve I chose in the  calibration tab, e.g bt.1886, gamma 2.2 or sRGB. After profiling the display and creating a 3d LUT, it  always shows the tones in Resolve corresponding to the gamma I chose for the 3d LUT. So the gamma-correction from the calibration tab applies only to noncolormanaged environments?

          1. Can you recommend a good video-player for macOS that does proper colormanagement?

            I’ve heard good things about mpv (which is a fork of mplayer), but haven’t used it in a while (probably over a year).

            Just to be sure if I understood calibration, profiling & colormanagement: It doesn‘t matter which gamma curve I chose in the calibration tab, e.g bt.1886, gamma 2.2 or sRGB. After profiling the display and creating a 3d LUT, it always shows the tones in Resolve corresponding to the gamma I chose for the 3d LUT. So the gamma-correction from the calibration tab applies only to noncolormanaged environments?

            Correct, yes.

Comments are closed.