Calibrating on Linux with Spyder 3 – all green

Home Forums Help and Support Calibrating on Linux with Spyder 3 – all green

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #26160

    Volker
    Participant
    • Offline

    Hi,

    I try to calibrate my Samsung SyncMaster 2243 on Suse 15.2 (Leap). I reset all settings of DisplayCAL to make sure I did not fat-finger something. Sadly, for whatever reason, my Spyder 3 thinks that green is missing.

    In the first step for manual display calibration, you can see this best (image). The screen is more or less fine but DisplayCAL saying it has to less green.

    If I bring the RGB values of the monitor to some point where the sensor is fine, the screen is horrible green (see attached image).

    If I calibrate like this, the resulting profile gives me a horrible green display, far from good.

    I tried another Spyder 3 to make sure it is not a hardware issue. But it behaves exactly the same.

    I know that this monitor is fine, because I calibrated it about a year ago with the same combination (DisplayCAL and Spyder 3). So the monitor should not be the issue.

    What can I do to make it work?

    Attachments:
    You must be logged in to view attached files.
    #26193

    Steve Smith
    Participant
    • Offline

    After you reset DisplayCal to defaults you need to go to the ‘Calibration’ tab, then change ‘White point’ from ‘as measured’ to ‘color temperature’, then set it to 6500K if that is what you want. (Appropriate for most use cases). Then change ‘Tone Curve’ to Gamma 2.2 (for computer monitor) or REC709 for tv … Then run the routine. Green should go away as you set monitor\tv for 6500K… Also check to see if you have loaded a proper ‘instrument mode’ at the top of the main DisplayCal page. (If one exists for the Spyder) – Did you load the Spyder software which includes the meter calibration, or let DisplayCal fetch it for you?

    • This reply was modified 2 weeks, 6 days ago by Steve Smith.
    • This reply was modified 2 weeks, 6 days ago by Steve Smith.
    • This reply was modified 2 weeks, 6 days ago by Steve Smith.
    #26203

    Volker
    Participant
    • Offline

    Thank you very much.

    I just tried. Mode was set to “LCD (generic)” and after a reset I have chosen exactly the values you mentioned. Directly while initial monitor calibration I realized that it says it is far not enough blue. Even if I turn blue to 100 (full), it seems not enough (but screen is very blue). So I tried with some “good looking” monitor settings and after calibration the screen gets very dark and blue. Not usable at all. The same for a second Spyder 3 hardware. It is definitely not the hardware.

    I installed the DisplayCAL version that comes with the package management of Suse 15.2 (Leap) (Version 3.5.3). The “Correction” dropdown is on “None”. There are some corrections available, starting with “Spyder 3 & Intelli Proof nnn…” or “Spyder 3 & Wide Gamut…”. But I have no idea what to select there. If I select “Auto”, it becomes “Auto (None)”. So it does not use one?

    I’m really confused now. Any idea what I can try next?

    #26204

    Volker
    Participant
    • Offline

    Update: I was able to calibrate the main monitor (Phlips 252B) on the same PC with no issues with the same spyder 3 device. The second monitor is still making problems. It is a Samsung SyncMaster 2243. I do not see why this is making a difference but maybe someone knows?

    #26205

    Steve Smith
    Participant
    • Offline

    Update: I was able to calibrate the main monitor (Phlips 252B) on the same PC with no issues with the same spyder 3 device. The second monitor is still making problems. It is a Samsung SyncMaster 2243. I do not see why this is making a difference but maybe someone knows?

    3.8.9.3 is the latest DisplayCal version. I think earlier versions had problems… Spyder probably has it’s own correction built in so “None” is correct… Also make sure to reset your monitor to default settings first. Not sure what else to suggest… Maybe trying calibrating with the bundled Spyder software to see if it works.

    #26209

    Volker
    Participant
    • Offline

    I just downloaded and tested with the most recent version 3.8.9.3 of DisplayCAL, but the problem stays. Currently, it makes everything to dark and blue.

    So this monitor has to stay uncalibrated while the other monitor on the same system calibrates perfectly 🙁

    #26211

    Steve Smith
    Participant
    • Offline

    That’s too bad. I’m sorry to hear that… I guess the best you could do is put up a white or gray image on both screens and manually match the color (temperature) of the bad one to the good one in a dark room… That’ll get you close in terms of 6500K … Then just set your ‘bad’ monitor to  2.2 gamma.

    Monitors are cheap today. Maybe time to  consider saving for a new one.

    #26218

    Volker
    Participant
    • Offline

    Yes, a new one seems a good idea. However, thank you very much for your help.

    #26233

    Steve Smith
    Participant
    • Offline

    You’re welcome. 🙂

    #26271

    Tamas Toth (ebola)
    Participant
    • Offline

    Hi @Volker!

    I had (yet have) a Spyder3 also and used it with Linux and Windows also (I have one another in my workplace with 20-30 monitor also with Linux and Windows). Spyder3 basically have lot of problems to determine the white balance of LED backlight monitors. This is now a well-known public information. I had lot of correct results in the past but maybe lot more of wrong results also where t depends on the type of the monitor. Usually I got yellowish result but there were greenish too. Slowly I educated myself (here at DisplayCal forum also) that Spyder3 sadly not the proper tool to measure whitepoint of LED backlight monitors. With old CCLF monitors my results were always fine but nowadays of course I have no such monitors (or just one Sony what I really like today yet/also).

    When I realized the problem the solution was to determine the whole balance with my eyes or leave the native what the monitor setting gave. This latter with old monitors will give faulty results so the only solution your eyes. Because I trained my eyes in photography and monitors for years I really think that nowadays I usually really can define  the correct white points but of course this method is far form the ideal especially when you would like to use your calibration device for exactly help on this. So my opinion that set the whilepoint based on what your eyes tell and use Spyder3 just for the proper curves/characteristics.

    Also Spyder3 because it’s technology can highly amortize through the years (more than some other instruments).

    Last year I bought one SpyderX (and leave the old Spyder3 in my drawer) and with it’s results I’m really happy but the most people will tell that buy one X-Rite device for the finest results. SpyderX for me is enough and good, and really fast what is not a main requirement but not bad if there is.

    Hope I could help on your question/problem.

    SpyderX Pro on Amazon  
    Disclosure: As an Amazon Associate I earn from qualifying purchases.

    #26272

    Tamas Toth (ebola)
    Participant
    • Offline
    #26274

    Volker
    Participant
    • Offline

    @Tamas Thanks for your tips, but I already ordered a second monitor yesterday 🙂 I will not spend any more time on that Samsung SyncMaster. It is old anyway, so time to replace it.

    #26277

    Tamas Toth (ebola)
    Participant
    • Offline

    A new monitor could be always a good choice (I love my 3/4 year old LG – UltraFine 24″ 4K)! (But not surely solve the requirement of calibration :D)

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Log in or Register

Display Calibration and Characterization powered by ArgyllCMS