Linearity issue with 3DLUT

Home Forums Help and Support Linearity issue with 3DLUT

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #141472

    Guillaume
    Participant
    • Offline

    So I had some problem with my CCFL monitor and I switched back to a small White LED LCD.

    I remembered that I had problems with 3DLUT generations. I used Perceptual Apperance and I noticed that the 3DLUT did color casts of various colors at different grayscale steps. In fact the ICM doesn’t show any behavior of that sort. I tried other rendering intents but I have other bugs in the process so I think the 3DLUT generator is broken. The monitor and the destination profile are good.

    My energy has been depleted by trying to solve this. I tried to uncheck VCGT and calibrate with the profiling only and nothing got better. So what could be done ?

    • This topic was modified 2 weeks, 1 day ago by Guillaume.
    #141474

    Ben
    Participant
    • Offline

    More details needed.   You used 3d lut in ?    Its not viewing angle of monitor?   Easy steps to do.  Get grey scale right and then make the 3d lut.   Possibility is the meter is wrong or display is unstable.   Funny how I get grey balance perfect and then it smoothes it out the next day with a tv vizio-v5-555.

    Wierd it does not show colors in grey scale with just a ICM.   Your white balance test in display test is good ?    Eyes are not always right.

    #141477

    Guillaume
    Participant
    • Offline

    The viewing angle is always something check with TN panels. The meter is right cause the 1DLUT from the ICM profile is near perfect. Monitor white point can’t be set manually. The problem is just the generated 3DLUT.

    #141478

    Guillaume
    Participant
    • Offline
    #141480

    Vincent
    Participant
    • Offline

    So I had some problem with my CCFL monitor and I switched back to a small White LED LCD.

    I remembered that I had problems with 3DLUT generations. I used Perceptual Apperance and I noticed that the 3DLUT did color casts of various colors at different grayscale steps. In fact the ICM doesn’t show any behavior of that sort. I tried other rendering intents but I have other bugs in the process so I think the 3DLUT generator is broken. The monitor and the destination profile are good.

    My energy has been depleted by trying to solve this. I tried to uncheck VCGT and calibrate with the profiling only and nothing got better. So what could be done ?

    Before attepmting to create a LU3TD you must verify if profile that describes display behavior is accurate. Check grayscale using “evaluate calibration grascale” or something like that in HTML report. Lowering speed may help too.

    Let’s assume that you have done it and custm profile is OK and calibrated VCGT grey is OK too, but doble check.

    If all is OK and yu are using DWWMLUT as intended, I saw posterization/banding on 6 bit TN laptops IDNK if that is your situation. Keep in ming that 65x65x65 only has 65 point for interpolating full grayscale.
    If you have a GPU with dithered outputs, like AMD cards, consider extracting VCGT data, inject that to simulated profile:
    -let’s call simulated.icm what you want to simulate with LUT3D on desktop, using DWMLUT
    -let’s call simulatedVCGT.icm the same as above but with VCGT injected (argyllcms commandline)
    -you create a LUT3D that transforms from simulated.icm to the custom XYZLUT profile made with displayCAL. DO NOT apply VCGT
    -you assign to OS display profile simulatedVCGT.icm alt ledt DIsplayCAL handle VCGT loading to GPU.

    Usually none of this is needed. DWMLUT applies dithering to 65 point greysacle interpolation results and all goes smooth…but if you have issues with DWMLUT and not with VCGT, the procedure explained above you get you the best of both worlds: colorspce simulation with DWMLUT and 256 VCGT entry for wild behaved monitors (as long as your GPU card suportd ditehring like AMDs do)

    #141484

    Guillaume
    Participant
    • Offline

    I tried your advice today but I always have weird greyscale once the 3DLUT is done. I gonna take a look at it tomorrow. I could find a solution. Thank you nonetheless, using command line tools isn’t a mystery anymore.

    #141486

    Guillaume
    Participant
    • Offline

    Yes ! I managed to fix the lowlight color cast. I used grossgrade to fix the blue channel. Grossgrade download here. A template has been added if you have similar problems

    Attachments:
    You must be logged in to view attached files.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Log in or Register

Display Calibration and Characterization powered by ArgyllCMS